Error 502 on the website www.fasterize.com
Incident Report for Fasterize
Resolved
Our hosting platform has fixed the issue on their side.
Posted 3 months ago. Apr 25, 2019 - 21:47 CEST
Investigating
We are investigating the issue with our hosting platform. The dashboard at my.fasterize.com is available.
Posted 3 months ago. Apr 25, 2019 - 16:28 CEST
This incident affected: Website.